搜索历史
热搜词
关于Bad version number in .class file的问题

推荐:Eclipse启动Tomcat报错: Bad version number in .class file

[ 问题现象   在Eclipse中启动Tomcat 6运行一个JavaWeb应用,但是Tomcat启动中报异常并且启动中止,异常信息如下: 致命的: Null component Catalina:type=JspMonitor

休息也差不多了,不写程序总觉得有点不对劲。试着自己写一个类似struts中的路径配置工具吧,就是根据资源的逻辑名来进行前进路径的寻址功能。很简单,但毕竟自己的探索嘛。

学习之路总是并不平坦的,

推荐:Eclipse中编译和运行时使用的JDK和JRE级别问题(关于"Bad version number in .class file"的异常解决)

[Bad version number in .class file异常,意思是“错误的版本号”。这是由于在eclipse中编译Java程序时所用的JDK版本高于运行时所用的JRE版本所致。如编译用JDK1.6,而运

这不,一开始就遇到问题了:Bad version number in .class file。版本不对?可是我用的java以及javac都是JDK5呀,怎么回事?除了编译版本跟运行版本不一致外是不会出现这种可能的。突然想起前几天试了一下JDK6,把Eclipse的JDK编译器选成JDK6了。果然,将其改回去JDK5就行了。

呵呵,这也算是个小插曲吧。说不定也有人跟我一样一不小心傻冒了一回。

推荐:MyEclipse中用Tomcat部署项目时遇到的问题1:java.lang.UnsupportedClassVersionError: Bad version number in .class file

[            原因:在服务器的机器上创建工程时用的是JDK6.0,但用SVN下载到自己的机器上时,本机用的是 JDK1.5,因此造成了编译出错。      解决方案:MyEclipse(6.5)中

主题:

分享:

相 关 推 荐

热 门 推 荐